New security vulnerability affects 1 in 20 Joomla websites

 

joomla-1-in-20

On Friday, the developer of the popular Breezing Forms add-on for Joomla announced a serious vulnerability affecting version 1.7.5 (build 762) and earlier.

Based on our research, we expect that about 1 in every 20 Joomla websites is affected by this vulnerability. 

Thus, we recommend that you check each and every one of your Joomla installs for this version of Breezing Forms. 

Pro tip: Watchful users can search all their sites at once to quickly identify any sites with Breezing Forms along with the installed version.

If your site(s) are affected, please secure the vulnerability using the steps outlined below.

REGULAR 1.7.5 UPGRADE INSTRUCTIONS

  1. Download and extract the patch provided by the developer. This will reveal a number of ZIP files and some folders as follows:
    1. <folder>component-files
    2. <folder>quickmode_additional_themes
    3. BREEZINGFORMS-UPDATE-README.txt
    4. mod_breezingforms.zip
    5. plg_breezingforms.zip
    6. THEMES_INSTALL_README.txt
  2. Apply the patch using the instructions in the BREEZINGFORMS-UPDATE-README.txt file as follows:
    1. Backup your website files and database.
    2. Copy the contents of the folder "component-files" using an FTP client to your web folder, just like you would do a Joomla! FTP update.
    3. (Re-)install the plugin and module if you are using one of these
    4. Clear your browser cache (important for backend)
    5. If you use assets like email templates, pdf templates and themes, then you'll find them in /media/breezingforms/ folder after upgrading. The old paths to these assets won't work from this build on! This is necessary as the upcoming BreezingForms version 1.8 will skip the FTP based upgrade procedure.

UPGRADING INSTRUCTIONS FROM JOOMLA 1.5 TO 1.6/1.7/2.5

  1. Do a fresh install of BreezingForms.
  2. Then, in your 1.5 site, export your forms with BreezingForms' form exporter (under Configuration) and import the forms on the Joomla! 1.6/1.7/2.5 site.
  3. After importing save each of your forms once to re-create the validation ids (not required for Classic Mode forms).
  4. Add your menu items, module positions and plugin like in Joomla! 1.5

1.8 LITE UPGRADE INSTRUCTIONS

Download the latest version and install as normal.

1.8 FULL UPGRADE INSTRUCTIONS

Please download the update from the membership area on http://crosstec.de/ and install as normal.

Customers with inactive subscriptions please write a short email with your username to This email address is being protected from spambots. You need JavaScript enabled to view it. to receive a free 1-month membership for upgrading.